配置以太网信道在运行集成的 Cisco IOS (Native模式)和Cisco路由器的Catalyst交换机之间

www.net130.com     日期:2004-11-17    浏览次数:
出处:cisco网站

前言

此示例配置展示 如何设置第三层以太网信道,没有VLAN中继,在运行 Cisco IOS (Native模式)的Cisco路由器和Catalyst 6500交换机之 间。 以太网信道可以根据用于的接口或端口的速度称为快速 以太信道(FEC)或Gigabit EtherChannel (GEC) ,形成以太网信道 。在本例中,二个快速以太网端口从Cisco路由器和 Catalyst 6500 交换机被包了到FEC。在本文过程中,术语 FEC,GEC、端口信道、信道和端口组全部将提到以太网信道。

本文包括配置文件从交换机和路由器 和仅输出从相关示例show命令。

创建 示例在本文,我们在实验室环境使用以下交换机带有被清除的配置 :

  • 运行Native IOS 12.1(8b)EX4的Catalyst 6500 交 换机

  • 运行12.1(9a)的Cisco 7500路由 器

交换机配置在本文适用于运行集成 Cisco IOS (Native Mode)的所有Catalyst 6000和任何Catalyst 系列4000系列交换机。

配置在本文在 隔离的实验室环境里实现。保证您使用它以前了解所有配置或命 令的潜在影响对您的网络。配置在所有设备被清除用 write erase命令保证他们有一 个默认配置。

注意: 保证在write erase 命令以后重新载入 设备冲洗所有非默认配置。

硬件和软件需求

Catalyst 6000/4000系列交换机(集成Cisco IOS (Native Mode))

  • 运行集成 Cisco IOS (Native Mode)的Catalyst 6000/4000系列交换机在所 有模块支持第二层和第三层以太网信道,与八个compatibaly配置的 以太网接口。必须所有配置所有接口在每个以太网信道必须 是同一速度和象第二层或第三层接口。

  • EtherChannel负载平衡能使用MAC地址,IP 地址或 者TCP端口号。注释,选择的方式适用于在交换机配置的所有 以太网信道。

  • Catalyst 6000 Cisco IOS 版本12.0 XE以上和 Catalyst 4000 Cisco IOS 12.1(8A)EW 或以上。

Cisco路由器

  • 当数据流 从其他路由协议在单条链路时,被发送IP数据流在端口信道接口被 分发。 桥接数据流在信息包根据第三层信息被分发。如果第三层信息在信息包不存在,数据流在第一条链路被发送。

  • 多样化的Cisco路由器支持以太网信 道。 查找在Cisco路由器支持以太网信道的平台和编码版本 ,使用Cisco.com功能导航。支持以太网信道路由器和IOS版 本的列表得到在快速以太信道(FEC)功能之下。参见 本文的 工具信息部分访问功能导 航。

关于以太网信道的硬件和软件需 求在其他思科产品,参见以下文件:

注意事项

在开辟物理接口之前,如果端口信道接口配置,首先 消除端口信道接口。通过输入信道组 发出命令,端口信道接口自动地被创建。

配置一条端口信道顺序在Catalyst 6000/4000 集成 Cisco IOS (Native Mode)是重要的。它推荐首先在输入 channel-group命令之前输入所有switchport 命令在一个物理接口 。当channel-group命令在一个物理接口(即int g1/1)改为被 输入在switchport命令之前,端口信道接口被创建,自动地删除 channel-group命令,并且成为第三层接口。物理接口现在成 为第二层接口并且及早被创建的端口信道接口没有物理接口联合它 。您不能再添加channel-group命令回到物理接口。相 反,如果输入switchport命令首先在一个物理接口然后添加 channel-group命令,端口信道接口自动地被创建并且继承所有 configured switchport命令。

默认 情况下在运行集成Cisco IOS (Native Mode)的Catalyst 6000交换 机,所有端口是第三层端口。默认情况下在运行集成 Cisco IOS (Native Mode)的Catalyst 4000交换机,所有端口是第二层端口。

网 络图

配置

备注和解释显示以 蓝色斜体

Catalyst 6500交换机(没有VLAN中继 )
 Building configuration...
  
 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot system flash slot0:c6sup11-jsv-mz.121-8b.EX4.bin
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !
 !-- In this example, we have configured Layer 3 EtherChannel.
 !-- For more details, refer to the following document:
 !-- Configuring Layer 3 and Layer 2 EtherChannel Switchport.
 !-- A logical port-channel interface is automatically created 
 !-- when ports are grouped in to a channel group.
 interface Port-channel 1
  ip address 11.1.1.2 255.255.255.0
  hold-queue 300 in
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !
 interface FastEthernet3/1
 no ip address
 !-- Port is member of channel group 1. Routers do not support Etherchannel 
 !-- negotiation (PAgP), so PAgP needs to be disabled.
 !-- On a Catalyst 4000 switch, all ports are Layer 2 port by default. Convert 
 !-- this port from physical Layer 2 port to physical Layer 3 port using the 
 !-- no switchport command.
 channel-group 1 mode on
 interface FastEthernet3/2
  no ip address
 !-- Port is member of channel group 1. Routers do not support Etherchannel 
 !-- negotiation (PAgP), so PAgP needs to be disabled.
 !-- On a Catalyst 4000 switch, all ports are Layer 2 port by default. Convert 
 !-- this port from physical Layer 2 port to physical Layer 3 port using the 
 !-- no switchport command.
 
 channel-group 1 mode on
 interface FastEthernet3/3
  no ip address
  switchport
  switchport mode access
 !
 (....Output is suppressed)
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

Cisco 7500路由器(没有VLAN中继)
(....Output is suppressed)
 !
 interface Port-channel1
  ip address 11.1.1.1 255.255.255.0
  hold-queue 300 in
 !
 interface FastEthernet0/0
  no ip address
  full-duplex
  channel-group 1
 !
 interface FastEthernet0/1
  no ip address   
  full-duplex                               
  channel-group 1
 (....Output is suppressed)

debug 及show 命令

  • 检查端口信道在集成 Cisco IOS交换问题以下命令:

    show EtherChannel端口信道<信道id >

  • 检查端口信道在Cisco IOS路由器 问题以下命令:

    show interface port-channel <信道 id >

示例显示命令输出

Catalyst 6500交换机

show etherchnl < channel-id > port-channel

Cisco 7500路由器

show interface port-channel < 信道id >

 Router# show interface Port-channel 1
 Port-channel1 is up, line protocol is up
 Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia
 0000.0000.0000)
 Internet address is 11.1.1.1/24
 MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load
 62/255
 Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
 ARP type: ARPA, ARP Timeout 04:00:00
 No. of members in this fechannel: 2
 Member 0 : FastEthernet0/0
 Member 1 : FastEthernet0/1
 Last input never, output never, output hang never
 Last clearing of "show interface" counters 10:51:55
 Queueing strategy: fifo
 Output queue 0/40, 0 drops; input queue 0/300, 0 drops
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 98281000 bits/sec, 8762 packets/sec
 4545 packets input, 539950 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 0 watchdog, 0 multicast
 0 input packets with dribble condition detected
 342251216 packets output, 3093422680 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 babbles, 0 late collision, 0 deferred
 0 lost carrier, 0 no carrier
 0 output buffer failures, 0 output buffers swapped out
相关新闻
无相关正文