OSPF的初始配置在点到点链路

www.net130.com     日期:2004-11-21    浏览次数:
出处:cisco网站

前言

在点到点链路例如高级 数据链路控制(HDLC)和PPP,开放式最短路径优先(OSPF)运行作 为一个点到点的网络类型。默认情况下此网络类型被启用。 本文显示OSPF 的示例配置在一条点到点链路。检查 运行OSPF的接口的网络类型,使用 show ip ospf interface命令。

示例如何用OSPF配置点到点网络也与HDLC封装一起使用。

使 用的组件

本文不限于特 定软件和硬件版本。

本文提供的信 息在特定实验室环境里从设备被创建了。用于本文的所有设 备开始了以一个缺省(默认)配置。如果在一个真实网络工 作,保证您使用它以前了解所有命令的潜在影响。

用IP地址配置

在此部分,您介绍用信 息配置通过一条点对点串行链路连接用在串行接口配置的IP 地址 运行OSPF路由协议的路由器。

注意: 找到其它信息关于用于本文的命令,使用 命令查找工具 (注册的用户)。

网络图

15a.gif

配置

此 部分使用如下所示的配置。

Router1

Router1
 !
 interface Loopback0
   ip address 3.3.3.3 255.255.255.255
 !
 interface Serial2
  ip address 1.1.1.2 255.255.255.0
 !
 router ospf 1
 network 1.1.1.0 0.0.0.255 area 0
 !

Router2

Router2
 !
 interface Loopback0
  ip address 2.2.2.2 255.255.255.255
 !
 interface Serial1/0
  ip address 1.1.1.1 255.255.255.0
  clockrate 2000000
 !
 router ospf 1
 network 1.1.1.0 0.0.0.255 area 0!

用未编号的接口配置

在此部分,您介绍用信息配置通过未编号的接口连 接和运行OSPF的路由器。

注意: 找到其它信息关于用于本文的命令,使用 命令查找工具 (注册的用户)。

网络图

15b.gif

配置

此部分使用如下所示的配置。

Router1

!
 interface Loopback0
  ip address 3.3.3.3 255.255.255.255
 !
 interface Serial0
  ip unnumbered loopback 0
  encapsulation ppp
 !
 router ospf 1
   network 3.3.3.0 0.0.0.255 area 0
 !
 

Router2

!
 interface Loopback0
  ip address 2.2.2.2 255.255.255.255
 !
 interface Serial0
  ip unnumbered loopback 0
  encapsulation ppp
 !
 router ospf 1
   network 2.2.2.0 0.0.0.255 area 0
 !

验证

此部分提供您能使用确认您的配置适当地工作的信息。

输 出解释器工具 支持 某些show命令 (注册的 用户) ,允许您查看show命令输出分析

验证用IP地址

下列是在Router1发出的 show ip ospf neighbor 命令的输出。
Router1#show ip ospf neighbor
    Neighbor ID   Pri   State       Dead Time       Address        Interface
      2.2.2.2      1   FULL/ -       00:00:32       1.1.1.1         Serial 0

此输出表示, Router1有一相邻,路由器ID是2.2.2.2和形成了完全邻接与此相邻 。地址1.1.1.1是Router2 Serial0接口的IP 地址

得知更多 show ip ospf neighbor命 令,参见 什么执行 show ip ospf neighbor命 令显示?

下列是 show ip ospf interface命令的输出 在Router1。 以下 表示OSPF网络类型为接口Serial0点到点。
Router1#show ip ospf interface serial 0
    Serial0 is up, line protocol is up
    Internet Address 1.1.1.2/24, Area 0
    Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
    Suppress hello for 0 neighbor(s)

同样地,输出为 show命令在Router2如下所示。
Router2#show ip ospf neighbor
    Neighbor ID     Pri    State     Dead Time     Address      Interface
     3.3.3.3         1     FULL/ -    00:00:32      1.1.1.2      Serial0
Router2#show ip ospf interface serial 0
    Serial0 is up, line protocol is up
    Internet Address 1.1.1.1/24, Area 0
    Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
     Hello due in 00:00:05
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
     Adjacent with neighbor 3.3.3.3
    Suppress hello for 0 neighbor(s)

验证与未编号的接口

show ip ospf nei ghbor 命令在Router1和Router2确认完全邻接。以下表示 OSPF网络类型为接口Serial0点到点。

得知更多 show ip ospf neighbor命 令,参见 什么执行 show ip ospf neighbor命 令显示?
Router1#show ip ospf neighbor
       Neighbor ID  Pri   State    Dead Time    Address      Interface
       2.2.2.2      1   FULL/ -    00:00:37    2.2.2.2       Serial0
Router1#show ip ospf interface serial 0
Serial0 is up, line protocol is up
   Internet Address 0.0.0.0/0, Area 0
   Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
     Hello due in 00:00:08
   Index 2/2, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1
     Adjacent with neighbor 2.2.2.2
   Suppress hello for 0 neighbor(s)

同样地,输出为 show命令在Router2如下 所示。
Router2#show ip ospf neighbor
       Neighbor ID   Pri   State   Dead Time   Address   Interface
       3.3.3.3        1   FULL/ -  00:00:30    3.3.3.3    Serial0
Router2#show ip ospf interface serial 0
Serial0 is up, line protocol is up
   Internet Address 0.0.0.0/0, Area 0
   Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
     Hello due in 00:00:08
   Index 2/2, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1
     Adjacent with neighbor 3.3.3.3
   Suppress hello for 0 neighbor(s)

相关新闻
无相关正文