组播快速配置指南

www.net130.com     日期:2004-6-14    浏览次数:

前言

IP组播是通过同时传送 单个信息流减少数据流到数千公司接收方和家的一种节省带宽的技 术。利用组播的应用程序包括视频会议,公司通信,远程教 育和软件分布、股票行情和新闻。本文讨论组播配置基础因 为不同组网情形。

在您开始之前 H2>

惯例

欲知关于文件惯例的更 多信息,请参阅 Cisco技术提示惯例

前提

此 文档没有特殊的先决条件。

使用的组件

本文不限于特定软件和硬件版本。

本文提供的信息在特定实验室环境里从设备被创建了 。用于本文的所有设备开始了以一个缺省(默认)配置。 如果在一个真实网络工作,保证您使用它以前了解所有命令 的潜在影响。

密集模式

Cisco推荐使用独立于协议的组播(PIM)稀疏模式, 特殊自动RP,在任何可能的情况下,特别是为新的配置。然 而,如果密集模式希望,配置 global命令 ip multicast-routing接口命令IP PIM稀疏-稠密-模式 在需要处理组 播数据流的每个接口。普通的需求,的所有配置在本文之内 ,是配置全局组播和配置PIM在接口。自 Cisco IOS® 版本11.1 ,接口命令 ip pim dense-modeip pim sparse-mode 可 能用ip pim sparse-dense-mode命令同时现在 配置。在此模式,如果组 是在密集模式下,接口被对待作为密集模式。如果组是在稀 疏模式下(例如,如果RP被知道),接口被对待作为稀疏模式。

注意: 注意: 在示例在本文过程中,"来源"表示组播数据流的来源并且"接 受器"表示组播数据流接收器。
mcast1.jpg

路由配置
 
ip multicast-routing
 interface ethernet0
 ip address <address> <mask>
 ip pim sparse-dense-mode 
 interface serial0
 ip address <address> <mask>
 ip pim sparse-dense-mode

路由器B配置
 
ip multicast-routing
 interface serial0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface ethernet0
 ip address <address> <mask>
 ip pim sparse-dense-mode

[page]

一个RP时的稀疏模式

在本例中,路由器A是应该典型地是路由器最接近来 源的RP。带有静态RP配置,所有路由器在PIM域必须有配置的 同样ip pim RP寻 址 命令。您能配置多个RP,但那里可以只是每个特定 组一个RP。

mcast2.jpg

路由配置
 
ip multicast-routing
 ip pim rp-address 1.1.1.1
 interface ethernet0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface serial0
 ip address 1.1.1.1 255.255.255.0
 ip pim sparse-dense-mode
 

路由器B配置
 
ip multicast-routing
 ip pim rp-address 1.1.1.1
 interface serial0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface ethernet0
 ip address <address> <mask>
 ip pim sparse-dense-mode

[page]

多个RP时的稀疏模式

在本例中,来源A发送到224.1.1.1,224.1.1.2和 224.1.1.3。Source-B发送到224.2.2.2,224.2.2.3和 224.2.2.4。您可能有一个路由器,或者RP 1或RP 2,是RP为 所有组,但如果希望不同的RP处理不同的组,您需要配置所有路由 器包括组队RP将服务。与静态RP配置的此类型,所有路由器 在PIM域必须有配置的 同样 ip pim rp-address address acl 命 令。您能也使用 自动 RP,是更加容易配置,达到同一个设置。

mcast3.jpg

RP 1配置
 
ip multicast-routing
 ip pim RP-address 1.1.1.1 2
 ip pim RP-address 2.2.2.2 3
 access-list 2 permit 224.1.1.1
 access-list 2 permit 224.1.1.2
 access-list 2 permit 224.1.1.3
 access-list 3 permit 224.2.2.2
 access-list 3 permit 224.2.2.3
 access-list 3 permit 224.2.2.4
 

RP 2配置
 
ip multicast-routing
 ip pim RP-address 1.1.1.1 2
 ip pim RP-address 2.2.2.2  3
 access-list 2 permit 224.1.1.1
 access-list 2 permit 224.1.1.2
 access-list 2 permit 224.1.1.3
 access-list 3 permit 224.2.2.2
 access-list 3 permit 224.2.2.3
 access-list 3 permit 224.2.2.4
 


路由器3和4的配置
 
ip multicast-routing
 ip pim RP-address 1.1.1.1  2
 ip pim RP-address 2.2.2.2  3
 access-list 2 permit 224.1.1.1
 access-list 2 permit 224.1.1.2
 access-list 2 permit 224.1.1.3
 access-list 3 permit 224.2.2.2
 access-list 3 permit 224.2.2.3
 access-list 3 permit 224.2.2.4

[page]

一个RP时的自动 RP

带有自动RP,您配置 RP发表他们的可用性作为RP和映射代理。RP使用 224.0.1.39 发送他们的公告。RP映射代理在寄发到 224.0.1.40的发现消息听宣布的信息包从RP,然后发送路由处理器 到组映射。这些发现消息是什么路由器的其余为他们的路由 处理器到组映射使用。您能使用也担当映射代理的一个RP, 或者您能配置多个RP和多个映射代理为冗余目的。

注意,当选择到来源RP公告我们极力推荐您使用一个 接口例如回环而不是一个物理接口的接口时。如果选择一个 物理接口,您取决于该接口总是哪些不可以总是实际情形,并且路 由器将停止通告本身作为RP 一旦物理接口断开。与回环接 口然而,它总是上并且从未断开因而保证RP将继续通过所有可用的 接口做通告自己作为RP,即使一个或很多其物理接口应该出故障。 回环接口必须有被启用的PIM并且通过内部网关协议(IGP) 或它做通告一定是可及的使用静态路由。

mcast4.jpg

路由配置
 
ip multicast-routing
 ip pim send-rp-announce loopback0 scope 16
 ip pim send-rp-discovery scope 16
 interface loopback0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface ethernet0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface serial0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 

路由器B配置
 
ip multicast-routing
 interface ethernet0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface serial0
 ip address <address> <mask>
 ip pim sparse-dense-mode

[page]

多个RP时的自动 RP

在本例中的访问控制 列表允许RP是仅RP为您希望的组。如果没有配置访问控制列 表,RP将是可用的作为RP为所有组。 如果二个RP发表他们的 可用性是RP为同一个组,映射代理使用"最高网际协议地址获胜"规 则将解决这些冲突。

影响哪个路由 器是RP为一个特定组,当时二个RP为该组宣布,您能用回环地址配 置每个路由器。放置更高的IP地址在首选RP,然后使用回环 接口作为宣布信息包的来源; 例如, ip pim发送路由处理器通告 loopback0。当使用时多个映射代理, 他们彼此监听发现信息包和映射代理带有最高IP地址wins并且成为 唯一的转发器224.0.1.40。

mcast5.jpg

RP 1配置
 
ip multicast-routing
 interface loopback0
 ip address <address> <mask>
 ip pim sparse-dense-mode 
 ip pim send-RP-announce loopback0 scope 16 group-list 1
 ip pim send-RP-discovery scope 16
 access-list 1 permit 239.0.0.0 0.255.255.255
 
 

RP 2配置
 
ip multicast-routing
 interface loopback0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 ip pim send-RP-announce loopback0 scope 16 group-list 1
 ip pim send-RP-discovery scope 16
 access-list 1 deny 239.0.0.0 0.255.255.255
 access-list 1 permit 224.0.0.0 15.255.255.255 

其它细节在自动RP可以这里查找: ftp://ftpeng.cisco.com/ipmulticast/autorp.html

[page]

DVMRP

您的网络服务提供商(ISP)可以建议您在互联网 (mbone)创建一条DVMRP隧道对他们为了获得访问到组播骨干网。 最低的命令配置DVMRP 隧道如下显示:

interface tunnel0  
 ip unnumbered <any pim interface>
 tunnel source <address of source>
 tunnel destination <address of ISPs mrouted box> 
 tunnel mode dvmrp  
 ip pim sparse-dense-mode

一般,ISP将让您建立隧道到运行"mrouted" (DVMRP) 的UNIX机器。如果他们改为让您建立隧道到另一台Cisco设备 ,使用默认GRE 封装隧道模式改为。

如果而不是简单收到组播信息包,您在mbone想要生 成组播信息包为其他发现,您需要做通告来源的子网。如果 您的组播源主机地址是131.108.1.1,您需要做通告该子网的存在对 mbone。默认情况下,直接连接的网络做通告带有权值1。 如果您的来源没有直接地连接到路由器用DVMRP隧道,配置以 下下面接口tunnel0:

ip dvmrp metric 1 list 3  
 access-list 3 permit 131.108.1.0 0.0.0.255  

注意: 您必须包括一个访问控制列表以上述命令防止 做通告整个单播路由表对mbone。

如 果您的设置是类似的到如下所示的那个,并且想要通过域传播DVMRP 路由,配置 ip dvmrp unicast-routing 在路由器A和B serial0接口。这将提供DVMRP路 由转发给然后把一张DVMRP路由表用于反向路径转发的PIM相邻(RPF) 。DVMRP学到的路由RPF比其他协议优先,除了直接连接的路 由。

mcast6.jpg

MBGP

MBGP是一个基本方式运载二个两套路由器:一 集为单播路由和一集为组播路由。MBGP提供控制必要决定组 播信息包哪里允许流。联合组播路由PIM使用路由构件数据分 布树。MBGP提供RPF路径,不是组播状态的创建。PIM 还是必要转发组播信息包。

mcast7.jpg

路由配置
 
ip multicast-routing
 interface loopback0
 ip pim sparse-dense-mode
 ip address 192.168.2.2 255.255.255.0
 interface serial0
 ip address 192.168.100.1 255.255.255.0
 interface serial1
 ip pim sparse-dense-mode
 ip address 192.168.200.1 255.255.255.0
 router bgp 123
 network 192.168.100.0 nlri unicast
 network 192.168.200.0 nlri multicast
 neighbor 192.168.1.1 remote-as 321 nlri unicast multicast
 neighbor 192.168.1.1 ebgp-multihop 255
 neighbor 192.168.100.2 update-source loopback0
 neighbor 192.168.1.1 route-map setNH out
 route-map setNH permit 10
 match nlri multicast
 set ip next-hop 192.168.200.1
 route-map setNH permit 20
 
 

路由器B配置
 
ip multicast-routing
 interface loopback0
 ip pim sparse-dense-mode
 ip address 192.168.1.1 255.255.255.0
 interface serial0
 ip address 192.168.100.2 255.255.255.0
 interface serial1
 ip pim sparse-dense-mode
 ip address 192.168.200.2 255.255.255.0
 router bgp 321
 network 192.168.100.0 nlri unicast
 network 192.168.200.0 nlri multicast
 neighbor 192.168.2.2 remote-as 123 nlri unicast multicast
 neighbor 192.168.2.2 ebgp-multihop 255
 neighbor 192.168.100.1 update-source loopback0
 neighbor 192.168.2.2 route-map setNH out
 route-map setNH permit 10
 match nlri multicast
 set ip next-hop 192.168.200.2
 route-map set NH permit 20
 
 

 

如果您的单播和组播结构是一致的(例如,在同一条 链路去),在配置的上主要的区别是用 nlri unicast multicast命 令。示例如下所示:

network 192.168.100.0 nlri unicast multicast
好处的 有MBGP运行一旦适当的结构是即使数据流横贯同样路径,不同的制 度可以被运用于单播BGP与组播BGP。

其它细节在MBGP可以这里查找:

MSDP

MSDP连接多个PIM-SM域。每个PIM-SM 域在其 他域使用其自己的独立RP(s)并且不必须依靠RP。MSDP允许域 发现组播源从其他域。如果也BGP协议与与MSDP对等体,您应 该为作为您为BGP执行的MSDP使用同样IP 地址。当MSDP进行 对等RPF检查时,盼望MSDP 对等体地址是BGP/MBGP提供它的同一个 地址当在RP在SA信息时执行一次路由表查找。只要有MSDP对 等体的之间,一个BGP/MBGP路径没有要求您然而,运行BGP/MBGP与 MSDP对等体。如果没有BGP/MBGP路径,并且如果有超过一个 MSDP 对等体,您必须使用 ip msdp default-peer命令 。在下面的示例,RP A是RP为其域并且RP B是RP为其域。

mcast8.jpg

路由配置
 
ip multicast-routing
 ip pim send-RP-announce loopback0 scope 16
 ip pim send-RP-discovery scope 16
 ip msdp peer 192.168.100.2
 ip msdp sa-request 192.168.100.2
 interface loopback0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface serial0
 ip address 192.168.100.1 255.255.255.0
 ip pim sparse-dense-mode
 
 

路由器B配置
 
ip multicast-routing
 ip pim send-RP-announce loopback0 scope 16
 ip pim send-RP-discovery scope 16
 ip msdp peer 192.168.100.1
 ip msdp sa-request 192.168.100.1
 interface loopback0
 ip address <address> <mask>
 ip pim sparse-dense-mode
 interface serial0
 ip address 192.168.100.2 255.255.255.0
 ip pim sparse-dense-mode

[page]

末端组播 路由

末端组播路由允 许您配置remote/stub 路由器作为IGMP代理。而不是充分参 与PIM ,这些末端路由器简单转发IGMP信息从主机到上行组播路由 器。

mcast9.jpg

路由器1配置
 
int s0
 ip pim sparse-dense-mode
 ip pim neighbor-filter 1
 access-list 1 deny 140.1.1.1


ip pim neighbor-filt er命令是需要的以便路由器1不认可路由器2作为PIM 相邻。如果配置路由器1在稀疏模式下,邻近过滤器是多余的。路由 器2在稀疏模式下不能运行。当在密集模式下,末端组播源能 充斥到骨干网路由器。

路由器2配置
 
ip multicast-routing
 int e0
 ip pim sparse-dense-mode
 ip igmp helper-address 140.1.1.2
 int s0
 ip pim sparse-dense-mode 

[page]

IGMP UDLR为卫星连接

UDLR为转发在一个单 向卫星链路的组播信息包提供一个方法的有反向信道的末端网络。 这于末端组播路由是类似的。没有此功能,uplink端 口路由器不能动态地了解哪个IP组播组寻址在单向链路转发,因为 下连路由器不能送回什么。

mcast10.jpg

rtr上行 -RTR配置
 
ip multicast-routing
 interface Ethernet0
 description Typical IP multicast enabled interface
 ip address 12.0.0.1 255.0.0.0
 ip pim sparse-dense-mode
 interface Ethernet1
 description Back channel which has connectivity to downlink-rtr
 ip address 11.0.0.1 255.0.0.0
 ip pim sparse-dense-mode
 interface Serial0
 description Unidirectional to downlink-rtr
 ip address 10.0.0.1 255.0.0.0
 ip pim sparse-dense-mode
 ip igmp unidirectional-link
 no keepalive
 
 

下连RTR配置
 
ip multicast-routing
 interface Ethernet0
 description Typical IP multicast enabled interface
 ip address 14.0.0.2 255.0.0.0
 ip pim sparse-dense-mode
 ip igmp helper-address udl serial0
 interface Ethernet1
 description Back channel which has connectivity to downlink-rtr
 ip address 13.0.0.2 255.0.0.0
 ip pim sparse-dense-mode
 interface Serial0
 description Unidirectional to uplink-rtr
 ip address 10.0.0.2 255.0.0.0
 ip pim sparse-dense-mode
 ip igmp unidirectional-link
 no keepalive

[page]
PIMv2 BSR
如果所有路由器在网络运行PIMv2,您能配置BSR而不 是自动RP。两个是非常类似的。与BSR配置,您配置 BSR候选(类似于RP 宣布在自动RP)和BSR (类似于自动RP映射代理) 。 配置BSR,遵从这些步骤:

在候选BSR配置:

ip pim bsr-candidate interface hash-mask-len pref
 
接 口 那里 包含候选 BSR IP地址。它推荐(但没要求) 无 用数据掩码Len 是相同横跨所有候选BSR。 候选BSR 带有最大的 宁可 值将选择作为BSR为此域。

示例命令使用方法如下显示:

ip pim bsr-candidate ethernet0 30 4
用于PIMv2 BSR收集候选RP信息和散发路由处理器设 置信息与每个组前缀相关。避免单点故障,超过一个路由器 在域可以配置作为候选BSR。

BSR在 候选BSR之中自动地选择,基于配置的首选值。在网络的骨干 网应该很好连接担当的路由器候选BSR和,与在网络的拨号区域相对 。

配置候选RP路由器。以下 示例显示候选RP,在interface ethernet0,为整个管理域范围地址 范围:

access-list 11 permit 239.0.0.0 0.255.255.255
 ip pim rp-candidate ethernet0 group-list 11
 
CGMP
配置CGMP,配置以下在面对交换机的路由器接口:

ip pim sparse-dense-mode
 ip cgmp
然后,配置以下在交换机:

set cgmp enable
IGMP探听
IGMP探听是可用的与 Catalyst 5000的版本4.1。IGMP探听要求一个 Supervisor III卡。 除PIM的之外配置不是必要配置IGMP探 听在路由器。路由器是仍然必要的带有IGMP 探听然而,提 供IGMP查询。

下面的示例在交换机 展示如何启用IGMP 探听:

Console> (enable) set igmp enable 
 IGMP Snooping is enabled. 
 CGMP is disabled.
如果设 法启用IGMP但CGMP已经启用,您将看见以下:

Console> (enable) set igmp enable 
 Disable CGMP to enable IGMP Snooping feature.
PGM
PGM是一个可靠组播传输协议为要求命令的应用程序 ,复制自由,组播数据发送从多源到多个接受器。PGM保证一 台接受器在组从传输和重发收到所有数据包或者能发现不可恢复的 信息包丢失。

没有PGM global命令 。PGM每个接口配置使用 ip pgm命令。 在接口 在路由器必须启用组播路由与PIM 一起。

[page]

MRM

MRM在一个大组播路由结构实现自动故障检测。 它设计使组播路由问题网络管理员警觉接近实时。

MRM有二个组件:MRM测试人 员和MRM 管理器。MRM测试人员是发送器和接受器。

MRM是在Cisco IOS 12.0(5)T和以 后可用的。 只有MRM测试人员和管理器需要运行支持MRM 的 IOS版本。

mcast11.jpg

测试发送 器配置
 
interface Ethernet0
   ip mrm test-sender 

测试接收器配置
 
interface Ethernet0
   ip mrm test-receiver 


测试管理器配置
 
ip mrm manager test1
  manager e0 group 239.1.1.1
  senders 1
  receivers 2 sender-list 1
  access-list 1 permit 10.1.1.2
  access-list 2 permit 10.1.4.2


输出从 show ip mrm manager命令在 测试管理器如下所示:
Test_Manager# show ip mrm manager
    Manager:test1/10.1.2.2 is not running
      Beacon interval/holdtime/ttl:60/86400/32
      Group:239.1.1.1, UDP port test-packet/status-report:16384/65535
      Test sender:
        10.1.1.2
      Test receiver:
        10.1.4.2
使用下面显 示的命令开始测试。 测试管理器寄发控制消息到测试发送器 和测试接收器如在测试参数配置。测试接收器加入从测试发 送器和监控程序测试信息包发送组。

Test_Manager# mrm start test1
  *Feb  4 10:29:51.798: IP MRM test test1 starts ...... 
 Test_Manager#
显示一个状态报告为测试管理器,输入以下命令:

Test_Manager# show ip mrm status 
 IP MRM status report cache: 
 Timestamp        Manager          Test Receiver   Pkt Loss/Dup (%)       Ehsr 
 *Feb  4 14:12:46 10.1.2.2         10.1.4.2        1            (4%)      29 
 *Feb  4 18:29:54 10.1.2.2         10.1.4.2        1            (4%)      15 
 Test_Manager#
输出表示,接受器发送了二个状态 报告(一条线路中的每一条)在给定时间。 每个报告包含一信息包丢失在间隔窗口(一秒默认值期间)。"Ehsr"值显示估计 的下个序号值从测试发送器。如果测试接收器锯重复的信息 包,它会显示负数在"Pkt Loss/Dup" 列。

终止测试,输入以下命令:

Test_Manager# mrm stop test1
 *Feb  4 10:30:12.018: IP MRM test test1 stops 
 Test_Manager#
当运行测试时,MRM发送器开始发送RTP 信息包到配 置的组地址在默认间隔200毫秒。接受器监控(预计)同样信 息包在同一个默认间隔。如果接受器在默认窗口间隔发现信 息包丢失五秒,寄发一个报告到MRM管理器。状态报告从接受 器在管理器可以使用show ip mrm status命令显示。

故障排除
某些最常见的问题在 网络面对当时实现IP组播是由于RPF故障或TTL设置时,当路由器不 转发组播数据流。为一个详细讨论关于这些和其他常见的问 题,症状和解决方法,看见 IP组播故障排除指南。

 

相关新闻
无相关正文