双ISP接入负载均衡加备份实验

www.net130.com     日期:2011-2-18    浏览次数:

一.拓朴图(在底下)
二. 实现目标:

内网172.16.10.0/24中的奇数地址(172.16.10.3/5/7/9)走ISP1,如果NAT与R1间的链路down掉,则走ISP2

内网172.16.10.0/24中的偶数地址(172.16.10.2/4/6/8)走ISP2,如果NAT与R2间的链路down掉,则走ISP1

 

 ;


三. 配置及注释:
1.NAT的配置:
NAT#show run
Building configuration...

Current configuration : 1696 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NAT
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
ip nat outside
serial restart-delay 0
!
interface Serial1/1
ip address 192.168.2.1 255.255.255.0
ip nat outside
serial restart-delay 0
!
interface Serial1/2
ip address 172.16.10.1 255.255.255.0
ip nat inside
ip policy route-map load //应用"load"的策略路由
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip nat pool R1 192.168.1.10 192.168.1.20 prefix-length 24 //配置R1的NAT地址池
ip nat pool R2 192.168.2.10 192.168.2.20 prefix-length 24 //配置R2的NAT地址池
ip nat inside source route-map ISP1 pool R1 overload //符合策略路由"ISP1"的使用R1定义的地址池
ip nat inside source route-map ISP2 pool R2 overload //符合策略路由"ISP2"的使用R2定义的地址池
ip classless
no ip http server
no ip http secure-server
!
!
!
ip access-list standard even //定义标准访问列表"even"
permit 172.16.10.0 0.0.0.254 //允许172.16.10.0中偶数的地址
access-list 1 permit 172.16.10.0 0.0.0.255 //允许NAT转换的地址范围
!
route-map load permit 10 //定义策略路由,用于实现负载分担和备份
match ip address even //匹配访问列表"even"的,也就是偶数的地址
set ip next-hop 192.168.2.2 //设置下一跳为192.168.2.2,也就是R2的接口地址
set ip default next-hop 192.168.1.2 //如果NAT和R2之间的链路down掉了,就使用默认的下一跳,也就是R1
!
route-map load permit 20 //不满足"load"系列号10的,就匹配20
set ip next-hop 192.168.1.2 //不匹配偶数的,也就是奇数的地址则下一跳为R1
set ip default next-hop 192.168.2.2 //如果NAT和R1之间的链路down掉了,就使用默认的下一跳,也就是R2
!
route-map ISP2 permit 10 //用于ISP2的策略路由
match ip address 1 //匹配访问列表1
match interface Serial1/1 //同时匹配出口为s1/1,也就是和R2相连的接口
!
route-map ISP1 permit 10 //用于ISP1的策略路由
match ip address 1 //匹配访问列表1
match interface Serial1/0 //同时匹配出口为s1/1,也就是和R2相连的接口
//一个访问列表只能匹配一个地址池,因此,我们必须用不同的出接口来区分。如果是h3c设备就无此问题
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password cisco
login
!
!
End
//基于不同的源地址网段做负载均衡比较简单,有不清楚的可以问我

本新闻共2页,当前在第1页  1  2  

分享道
相关新闻