配置多个HSRP组 是HSRP协议的扩展

www.net130.com     日期:2011-12-1    浏览次数:

  多组HSRP协议(MHSRP)是HSRP协议的扩展,它允许路由器的一个端口隶属于多个热备份组。MHSRP协议需要Cisco IOS 10.3或以上的版本支持,并且路由器硬件允许一个以太网端口绑定多个单点广播MAC地址,如AGS、AGS+以及Cisco 7000系列路由器。如图3所示,这些特殊路由器硬件允许配置路由器中的一个端口,使得该路由器成为多个备份组的备份路由器。

  在图3中,路由器A的以太网端口0属于组1,路由器B的以太网端口0属于组1、2和3,路由器C的以太网端口0属于组2,路由器D的以太网端口0属于组3。可以按照部门组织结构来建立各组。在这中情况下,组1可能表示工程部门,组2表示制造部门,组3表示财务部门。

  路由器B配置为组1和组2的主动路由器,组3的备份路由器。路由器D配置为组3的主动路由器。如果路由器D因为某种原因失效,路由器B将执行路由器D的数据转发功能,从而允许财务部门的用户可以继续访问其他子网的数据。

  以下是路由器A的配置:

  hostname RouterA

  !

  interface ethernet 0

  ip address 1.0.0.1 255.0.0.0

  standby 1 ip 1.0.0.5

  standby authentication sclara

  !

  interface serial 0

  ip address 2.0.0.1 255.0.0.0

  !

  router eigrp 1

  network 1.0.0.0

  network 2.0.0.0

  以下是路由器B的配置,要求路由器B必须是AGS、AGS+或者Cisco 7000系列路由器:

  hostname RouterB

  !

  interface ethernet 0

  ip address 1.0.0.2 255.0 0.0

  standby 1 ip 1.0.0.5

  standby 1 priority 110

  standby 1 preempt

  standby 1 authentication sclara

  standby 2 ip 1.0.0.6

  standby 2 priority 110

  standby 2 preempt

  standby 2 authentication mtview

  standby 3 ip 1.0.0.7

  standby 3 preempt

  standby 3 authentication svale

  !

  interface serial 0

  ip address 3.0.0.1 255.0.0.0

  !

  router eigrp 1

  network 1.0.0.0

  network 3.0.0.0

  以下是路由器C的配置:

  hostname RouterC

  !

  interface ethernet 0

  ip address 1.0.0.3 255.0 0.0

  standby 2 ip 1.0.0.6

  standby 2 authentication mtview

  !

  interface serial 0

  ip address 4.0.0.1 255.0.0.0

  !

  router eigrp 1

  network 1.0.0.0

  network 4.0.0.0

  以下是路由器D的配置:

  hostname RouterD

  !

  interface ethernet 0

  ip address 1.0.0.4 255.0 0.0

  standby 3 ip 1.0.0.7

  standby 1 priority 110

  standby 1 preempt

  standby 3 authentication svale

  !

  interface serial 0

  ip address 4.0.0.1 255.0.0.0

  !

  router eigrp 1

分享道
相关新闻